Re: [PATCH v5 06/17] mm/mm_init: factor out pfn_to_zone()

From: Qi Zheng

Date: Tue Aug 25 2026 - 06:55:06 EST




On 8/25/26 4:45 PM, Muchun Song wrote:
pfn_to_zone() in hugetlb_vmemmap.c duplicates the zone lookup logic in
__init_deferred_page().

Move it to mm_init.c, declare it in mm/mm_init.h, and reuse it from
__init_deferred_page() and HugeTLB early vmemmap initialization instead
of open-coding the zone walk there.

Signed-off-by: Muchun Song <songmuchun@xxxxxxxxxxxxx>
Acked-by: Mike Rapoport (Microsoft) <rppt@xxxxxxxxxx>

Acked-by: Qi Zheng <qi.zheng@xxxxxxxxx>

Thanks,
Qi