Re: [PATCH v4] staging: rtl8723bs: refactor traffic_stat access in collect_traffic_statistics

From: Greg KH

Date: Tue Aug 25 2026 - 11:43:39 EST


On Fri, Aug 07, 2026 at 08:35:29PM +0530, Mirza Ishan Beg wrote:
> Replace repetitive `pdvobjpriv->traffic_stat.` dereferencing with a local
> pointer `ts` to improve readability and reduce line length. This resolves
> multiple checkpatch line-length warnings without manual wrapping.
>
> Suggested-by: Nikolay Kulikov <nikolayof23@xxxxxxxxx>
> Signed-off-by: Mirza Ishan Beg <seedandsyntax@xxxxxxxxx>
> Link: https://lore.kernel.org/linux-staging/agDaGJ5UKndFUNPY@archlinux/
> Reported-by: kernel test robot <lkp@xxxxxxxxx>
> Closes: https://lore.kernel.org/oe-kbuild-all/202608070159.puVnOVxb-lkp@xxxxxxxxx/
> Closes: https://lore.kernel.org/oe-kbuild-all/202608070545.V0T8UE77-lkp@xxxxxxxxx/
> ---
> Changes in v4:
> - Fix incorrect struct type: use `rtw_traffic_statistics` instead of `traffic_stat` (reported by kernel test robot)
> drivers/staging/rtl8723bs/core/rtw_cmd.c | 25 ++++++++++++------------
> 1 file changed, 13 insertions(+), 12 deletions(-)

Where is the 1-3 version info?

And the "Closes:" isn't correct, 0-day was responding to previous errors
you made in other versions of this series, not the original code.
THere's nothing wrong with the original code that needs to be "Closed".

thanks,

greg k-h