[GIT PULL] power sequencing updates for v7.3-rc1 - part 2

From: Bartosz Golaszewski

Date: Wed Aug 26 2026 - 04:16:32 EST


Linus,

Please pull the following one-commit PR for the v7.3 cycle. This is part 2
of the power sequencing updates and it does a tree-wide rename of two of the
public functions to better reflect their actual semantics. This has been acked
by the maintainers of the affected subsystems.

Thanks,
Bartosz

The following changes since commit a39ac4651e3b9d2ca78b6d3dc2a81a6bd25fa616:

power: sequencing: pcie-m2: Match WCN6855 and WCN7851 UART BT variants by subdevice ID (2026-07-24 14:36:39 +0200)

are available in the Git repository at:

git://git.kernel.org/pub/scm/linux/kernel/git/brgl/linux.git tags/pwrseq-updates-for-v7.3-rc1-part2

for you to fetch changes up to d51fc9d4cd6eb18ac82913d83ecf7bd8c85f71ee:

power: sequencing: rename pwrseq_power_on/off() to pwrseq_enable/disable() (2026-08-26 10:05:45 +0200)

----------------------------------------------------------------
power sequencing updates for v7.3-rc1

- rename pwrseq_power_on/off() to pwrseq_enable/disable() tree-wide

----------------------------------------------------------------
Bartosz Golaszewski (1):
power: sequencing: rename pwrseq_power_on/off() to pwrseq_enable/disable()

Documentation/driver-api/pwrseq.rst | 4 ++--
drivers/bluetooth/hci_qca.c | 4 ++--
drivers/gpu/drm/imagination/pvr_power.c | 4 ++--
drivers/net/wireless/ath/ath10k/snoc.c | 6 +++---
drivers/pci/pwrctrl/generic.c | 4 ++--
drivers/pci/pwrctrl/pci-pwrctrl-pwrseq.c | 4 ++--
drivers/power/sequencing/core.c | 16 ++++++++--------
include/linux/pwrseq/consumer.h | 8 ++++----
8 files changed, 25 insertions(+), 25 deletions(-)