Re: [PATCH v3 1/3] mm: khugepaged: fix swap entry value to folio_pfn()

From: David Hildenbrand (Arm)

Date: Wed Aug 26 2026 - 04:18:17 EST


On 8/26/26 10:11, Lorenzo Stoakes (ARM) wrote:
> On Wed, Aug 26, 2026 at 10:08:58AM +0200, David Hildenbrand (Arm) wrote:
>> On 8/26/26 10:07, Lorenzo Stoakes (ARM) wrote:
>>>
>>> I find this name... problematic :)
>>
>> Elaborate.
>
> It's overly long, I read it and am confused as to what is 'problematic' or not,
> it reads weirdly in English and pfn_xxx is the usual convention for naming of
> pfn's anyway.

Excuse me, what? Are you now just making up arguments?

>
> I made a suggestion in the reply as to how to refactor this to avoid the need
> for assigning the name like that anyway, if you branch the result ==
> SCAN_SUCCEED then it's implied.

How is something that doesn't state the purpose make it any clearer?

--
Cheers,

David