Re: [PATCH v3 4/4] phy: qualcomm: qmp-combo: Rework DP PHY runtime configuration

From: Abel Vesa

Date: Fri Aug 28 2026 - 06:18:08 EST


On 26-08-28 15:13:16, Nabige Aala wrote:
> From: Ritesh Kumar <ritesh.kumar@xxxxxxxxxxxxxxxx>
>
> Rework the DP PHY runtime configuration by:
> - Extracting common DP PHY initialization sequence into
> qmp_combo_configure_dp_phy_common() function that is shared
> between qmp_v456_configure_dp_phy() and qmp_v8_configure_dp_phy()
> - Adding dp_aux_cfg2 field to qmp_phy_cfg structure to store the
> hardware-specific AUX_CFG2 register value
> - Defining named constants (QSERDES_DP_PHY_AUX_CFG2_V456 and
> QSERDES_DP_PHY_AUX_CFG2_V8) for better code readability
> and maintainability
> - Adding validation check to ensure dp_aux_cfg2 is properly
> configured for all hardware variants
> - Updating qmp_v8_dp_aux_init() with corrected power-down control and
> bias enable settings
> - Modifying qmp_v8_configure_dp_clocks() to add VCO divider programming
> and update auxless/LFPS timing parameters
> - Refining qmp_v8_configure_dp_phy() with updated driver enable values,
> TSYNC override sequence, and additional status checks for proper
> PHY lock verification
>
> Signed-off-by: Ritesh Kumar <ritesh.kumar@xxxxxxxxxxxxxxxx>
> Signed-off-by: Mahadevan P <mahadevan.p@xxxxxxxxxxxxxxxx>
> Signed-off-by: Nabige Aala <nabige.aala@xxxxxxxxxxxxxxxx>

Reviewed-by: Abel Vesa <abel.vesa@xxxxxxxxxxxxxxxx>