Re: [PATCH] mm/oom_kill, proc: replace magic number 1000 with OOM_SCORE_ADJ_MAX

From: Andrew Morton

Date: Sat Aug 29 2026 - 23:14:33 EST


On Tue, 11 Aug 2026 11:36:08 +0800 Ye Liu <ye.liu@xxxxxxxxx> wrote:

> From: Ye Liu <liuye@xxxxxxxxxx>
>
> In oom_badness() and proc_oom_score(), the oom_score_adj normalization
> uses a hardcoded 1000, which is the value of OOM_SCORE_ADJ_MAX defined
> in include/uapi/linux/oom.h. Other code in the kernel (e.g.
> fs/proc/base.c oom_adj handling) already uses OOM_SCORE_ADJ_MAX for
> the same purpose.
>
> Replace the magic number with the macro for consistency and
> readability. No functional change.
>
> ...
>
> --- a/fs/proc/base.c
> +++ b/fs/proc/base.c
> @@ -594,7 +594,8 @@ static int proc_oom_score(struct seq_file *m, struct pid_namespace *ns,
> * exporting for a long time so userspace might depend on it.
> */
> if (badness != LONG_MIN)
> - points = (1000 + badness * 1000 / (long)totalpages) * 2 / 3;
> + points = (OOM_SCORE_ADJ_MAX +
> + badness * OOM_SCORE_ADJ_MAX / (long)totalpages) * 2 / 3;
>
> seq_printf(m, "%lu\n", points);
>
> diff --git a/mm/oom_kill.c b/mm/oom_kill.c
> index 5f372f6e26fa..08bff7a55db8 100644
> --- a/mm/oom_kill.c
> +++ b/mm/oom_kill.c
> @@ -230,7 +230,7 @@ long oom_badness(struct task_struct *p, unsigned long totalpages)
> task_unlock(p);
>
> /* Normalize to oom_score_adj units */
> - adj *= totalpages / 1000;
> + adj *= totalpages / OOM_SCORE_ADJ_MAX;
> points += adj;
>
> return points;

AI review suggests that this is a misinterpretation of "1000"?

https://sashiko.dev/#/patchset/20260811033609.3992348-1-ye.liu@xxxxxxxxx