[PATCH 5/8] mm/swapfile: use folio_page_swap_entry()

From: Tal Zussman

Date: Sun Aug 30 2026 - 06:35:06 EST


folio_dup_swap() and folio_put_swap() open-code the swap entry
computation from folio->swap and folio_page_idx(). Use
folio_page_swap_entry() instead.

No functional change.

Signed-off-by: Tal Zussman <tz2294@xxxxxxxxxxxx>
---
mm/swapfile.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/mm/swapfile.c b/mm/swapfile.c
index 58db70424253..c7b8e69a1227 100644
--- a/mm/swapfile.c
+++ b/mm/swapfile.c
@@ -1810,7 +1810,7 @@ int folio_dup_swap(struct folio *folio, struct page *page)
VM_WARN_ON_FOLIO(!folio_test_swapcache(folio), folio);

if (page) {
- entry.val += folio_page_idx(folio, page);
+ entry = folio_page_swap_entry(folio, page);
nr_pages = 1;
}

@@ -1837,7 +1837,7 @@ void folio_put_swap(struct folio *folio, struct page *page)
VM_WARN_ON_FOLIO(!folio_test_swapcache(folio), folio);

if (page) {
- entry.val += folio_page_idx(folio, page);
+ entry = folio_page_swap_entry(folio, page);
nr_pages = 1;
}


--
2.39.5