Re: [PATCH v5 07/20] iio: adc: ad7768: Add power mode helper
From: Andy Shevchenko
Date: Mon Aug 31 2026 - 00:45:08 EST
On Fri, Aug 28, 2026 at 05:30:30PM +0200, Janani Sunil wrote:
> Describe each power mode and its internal master-clock divisor in a
> table. Replace the open-coded fast-mode setup with a helper that records
> the active mode, preparing for dynamic mode selection.
...
> struct ad7768_state {
> struct clk *mclk;
> unsigned int datalines;
> enum ad7768_clock_source clock_source;
> + unsigned int power_mode_idx;
> const struct ad7768_chip_info *chip_info;
> struct iio_backend *back;
> unsigned int vref_uV[2];
Looking at even this context I think there is better location for a new member,
run `pahole` to confirm and amend.
> };
--
With Best Regards,
Andy Shevchenko