Re: [PATCH net-next v3 3/3] net: dsa: realtek: rtl83xx: use dev_err_cast_probe() for reset GPIO

From: Luiz Angelo Daros de Luca

Date: Mon Aug 31 2026 - 09:16:26 EST


> Replace the open-coded dev_err() + ERR_CAST() on the reset GPIO error
> path with dev_err_cast_probe(), matching the reset controller above and
> staying quiet on -EPROBE_DEFER.
>
> Signed-off-by: Oleksij Rempel <o.rempel@xxxxxxxxxxxxxx>
> ---
> Changes since v2:
> - Added this patch
> ---
> drivers/net/dsa/realtek/rtl83xx.c | 6 ++----
> 1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/net/dsa/realtek/rtl83xx.c b/drivers/net/dsa/realtek/rtl83xx.c
> index d6d243131fd2..8121ec12fd8b 100644
> --- a/drivers/net/dsa/realtek/rtl83xx.c
> +++ b/drivers/net/dsa/realtek/rtl83xx.c
> @@ -212,10 +212,8 @@ rtl83xx_probe(struct device *dev,
> "failed to get reset control\n");
>
> priv->reset = devm_gpiod_get_optional(dev, "reset", GPIOD_OUT_LOW);
> - if (IS_ERR(priv->reset)) {
> - dev_err(dev, "failed to get RESET GPIO\n");
> - return ERR_CAST(priv->reset);
> - }
> + if (IS_ERR(priv->reset))
> + return dev_err_cast_probe(dev, priv->reset, "failed to get RESET GPIO\n");
>
> dev_set_drvdata(dev, priv);
>
> --
> 2.47.3
>

Nice!

Reviewed-by: Luiz Angelo Daros de Luca <luizluca@xxxxxxxxx>