Re: [PATCH v3 1/9] ASoC: dt-bindings: qcom,qaif-cpu: Add binding

From: Harendra Gautam

Date: Tue Sep 01 2026 - 04:10:22 EST


> > + qaif_cpu: audio-controller@a000000 {
> > + compatible = "qcom,shikra-qaif-cpu";
>
> The DT binding filename and compatible string do not match (qcom,qaif-cpu.yaml vs qcom,shikra-qaif-cpu).
> Usually DT binding filenames are aligned with the compatible string for clarity.
> Is there a reason for the naming mismatch?
The filename reflects the controller; the compatible is
variant-specific. This follows the same convention as
qcom,lpass-cpu.yaml.
>
> > + reg = <0x0 0x0a000000 0x0 0x20000>;
> > + interrupts = <0 331 4>;
>
> Could we use the standard GIC and IRQ type macros instead of raw values here for readability?
> Ex: interrupts = <GIC_SPI 331 IRQ_TYPE_LEVEL_HIGH>;
Will update the example to use GIC_SPI and IRQ_TYPE_LEVEL_HIGH.
-Harendra