Re: [PATCH 2/3] staging: rtl8723bs: split chained assignments in _rtw_open_pktfile()

From: Greg KH

Date: Tue Sep 01 2026 - 06:13:52 EST


On Thu, Aug 27, 2026 at 09:21:36AM +0300, Godana Emiru wrote:
> Split the two chained assignments into separate statements, one
> variable per line, preserving the original assignment order.
>
> No functional change.
>
> Signed-off-by: Godana Emiru <godanaemiru@xxxxxxxxx>
> ---
> drivers/staging/rtl8723bs/os_dep/xmit_linux.c | 6 ++++--
> 1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/rtl8723bs/os_dep/xmit_linux.c b/drivers/staging/rtl8723bs/os_dep/xmit_linux.c
> index 7a9d2fabc..c5f90a906 100644
> --- a/drivers/staging/rtl8723bs/os_dep/xmit_linux.c
> +++ b/drivers/staging/rtl8723bs/os_dep/xmit_linux.c
> @@ -14,8 +14,10 @@ uint rtw_remainder_len(struct pkt_file *pfile)
> void _rtw_open_pktfile(struct sk_buff *pktptr, struct pkt_file *pfile)
> {
> pfile->pkt = pktptr;
> - pfile->cur_addr = pfile->buf_start = pktptr->data;
> - pfile->pkt_len = pfile->buf_len = pktptr->len;
> + pfile->buf_start = pktptr->data;
> + pfile->cur_addr = pfile->buf_start;
> + pfile->buf_len = pktptr->len;
> + pfile->pkt_len = pfile->buf_len;

This is harder to read now, right? Please see the archives for a
suggestion as to how to make this more understandable.

thanks,

greg k-h