Re: [PATCH v7 04/17] drm/panfrost: Move debugfs initialisation to relevant subsystems

From: Boris Brezillon

Date: Tue Sep 01 2026 - 08:44:08 EST


On Fri, 28 Aug 2026 21:56:44 +0100
Adrián Larumbe <adrian.larumbe@xxxxxxxxxxxxx> wrote:

> @@ -757,4 +758,28 @@ void panfrost_gem_debugfs_print_bos(struct panfrost_device *pfdev,
> seq_printf(m, "Total size: %zd, Total resident: %zd, Total reclaimable: %zd\n",
> totals.size, totals.resident, totals.reclaimable);
> }
> +
> +static int panfrost_gems_show(struct seq_file *m, void *data)
> +{
> + struct drm_info_node *node = m->private;
> + struct panfrost_device *pfdev = to_panfrost_device(node->minor->dev);
> +
> + panfrost_gem_debugfs_print_bos(pfdev, m);
> +
> + return 0;
> +}
> +
> +static struct drm_info_list panfrost_debugfs_list[] = {
> + {"gems",
> + panfrost_gems_show, 0, NULL},
> +};
> +
> +int panfrost_gems_debugfs_init(struct drm_minor *minor)


nit: I would rename that one panfrost_gem_debugfs_init().

The rest looks good

Reviewed-by: Boris Brezillon <boris.brezillon@xxxxxxxxxxxxx>

> +{
> + drm_debugfs_create_files(panfrost_debugfs_list,
> + ARRAY_SIZE(panfrost_debugfs_list),
> + minor->debugfs_root, minor);
> +
> + return 0;
> +}