Re: [PATCH v3 1/2] mm/gup_test: prevent overflow in GUP batch calculation
From: Kiryl Shutsemau
Date: Tue Sep 01 2026 - 09:30:49 EST
On Tue, Sep 01, 2026 at 04:52:11PM +0530, Sarthak Sharma wrote:
> Hi Kiryl!
>
> On 9/1/26 4:05 PM, Kiryl Shutsemau wrote:
> > On Tue, Sep 01, 2026 at 02:04:51PM +0530, Sarthak Sharma wrote:
> > What about this:
> >
> > nr = min(nr, (end - addr) / PAGE_SIZE);
> > next = addr + nr * PAGE_SIZE;
> >
> > Seems to be easier to follow, no?
>
> Yup, this would be cleaner. Do you want me to respin with this changed?
Let's wait a bit for more feedback.
--
Kiryl Shutsemau / Kirill A. Shutemov