Re: [PATCH v10 02/12] cxl: Pass decoder settings to HDM commit helpers

From: Srirangan Madhavan

Date: Tue Sep 01 2026 - 21:52:26 EST


On 8/20/26 3:21 PM, Dave Jiang wrote:
This function made a round trip from hdm.c to resource.c back to hdm.c between patch 1 and 2.
I think there's some code duplication here with this function. What do you think of something like:
Ack. Addressed this in v11 using the cxl_decoder_snapshot() structure you suggested. The switch-target helper no longer makes a round trip through and the duplicated endpoint/switch setup is consolidated in the snapshot helper. I retained the separately requested argument ordering and target-list bounds handling.

--
Regards,
Srirangan