Re: [PATCH v24 05/15] mmc: renesas_sdhi: Add SDHI_SD_CLK_CTL_DIV1 macro for 1/1 option

From: Wolfram Sang

Date: Wed Sep 02 2026 - 07:18:42 EST


On Thu, Aug 20, 2026 at 06:16:35PM +0100, Biju wrote:
> From: Biju Das <biju.das.jz@xxxxxxxxxxxxxx>
>
> Replace the magic number 0xff, used for selecting the SD clock 1/1
> divider option, with a new SDHI_SD_CLK_CTL_DIV1 macro. This improves
> readability and self-documents the purpose of the value at each use
> site (setting/clearing the divider bits and comparing against
> CLK_CTL_DIV_MASK).
>
> No functional change.
>
> Signed-off-by: Biju Das <biju.das.jz@xxxxxxxxxxxxxx>

Reviewed-by: Wolfram Sang <wsa+renesas@xxxxxxxxxxxxxxxxxxxx>

Attachment: signature.asc
Description: PGP signature