Re: [PATCH RFC v2 04/19] drm/bridge: panel: rename drm_bridge_is_panel() -> drm_bridge_is_panel_bridge()

From: Luca Ceresoli

Date: Thu Sep 03 2026 - 12:16:38 EST


Hello Albert,

On Thu Sep 3, 2026 at 3:59 PM CEST, Albert Esteve wrote:
> On Thu, Sep 3, 2026 at 10:12 AM Luca Ceresoli <luca.ceresoli@xxxxxxxxxxx> wrote:
>>
>> Work is in progress for every drm_panel to embed a drm_bridge, and for that
>> a function will be needed in the drm_panel API to tell whether a bridge
>> represents a panel or something else. The ideal name for that will be
>> drm_bridge_is_panel(), which however is already in use by the panel_bridge.
>>
>> Rename the current function in the panel_bridge API to
>> drm_bridge_is_panel_bridge(), which is more precise and frees up the
>> drm_bridge_is_panel() for future use in the drm_panel API.
>>
>> No functional changes, just renaming a function treewide.
>>
>> Signed-off-by: Luca Ceresoli <luca.ceresoli@xxxxxxxxxxx>
>> ---
>> drivers/gpu/drm/bridge/panel.c | 8 ++++----
>> drivers/gpu/drm/display/drm_bridge_connector.c | 2 +-
>> include/drm/drm_bridge.h | 4 ++--
>> 3 files changed, 7 insertions(+), 7 deletions(-)
>
> Reviewed-by: Albert Esteve <aesteve@xxxxxxxxxx>
>
> Thanks for cc'ing me :)

You're welcome. Sorry for not having done it since v1.

Luca

--
Luca Ceresoli, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com