[PATCH 0/2] crypto: use designated initializers for acpi_device_id
From: Pawel Zalewski (The Capable Hub)
Date: Thu Sep 03 2026 - 13:17:58 EST
This series is converting lists that contain the acpi_device_id
struct, which is defined in the include/linux/device-id/acpi.h
to make use of named initializers (which they do not use currently).
This work is part of the on going effort in the kernel associated
with device-ids [1]
The plan is to convert acpi_device_id::driver_data to have an anonymous
union, similarly to what was introduced for PCI and I2C device ID tables.
The goal is to increase type-safety (as most of the existing casts are gone),
to improve readability and to make use intent a bit more clear:
```
union {
kernel_ulong_t driver_data;
const void *driver_data_ptr;
}
```
But for that to work all lists containing the structs need to use named
initializers first to avoid triggering -Wmissing-braces. I already have
patches that implement this and touching a lot of kernel subsystmes that
use the acpi_device_id struct and that list keeps on growing. Therefore,
I have decided to split the series per every subsystem into:
- pre-clean-ups that convert the lists to use named initializers (this series)
- actual implementations that make some of the modules use the new driver_data_ptr
That way the task can be fragmented into manageable and independent
chunks of work and makes this effort easier to review.
Tested builds on x86-64 and a64 in Yocto using 7.3-rc1.
[1] https://lore.kernel.org/all/cover.1780048925.git.u.kleine-koenig@xxxxxxxxxxxx/
Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@xxxxxxxxxxxxxxxxxxxx>
---
Pawel Zalewski (The Capable Hub) (2):
crypto: ccp: use named initializers for acpi_device_id
crypto: hisilicon/sec: use named initializers for acpi_device_id
drivers/crypto/ccp/sp-platform.c | 4 ++--
drivers/crypto/hisilicon/sec/sec_drv.c | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
---
base-commit: 940de590b839f71d6dc846160534bf202401b8b7
change-id: 20260903-acpi-crypto-c16d403f1022
Best regards,
--
Pawel Zalewski (The Capable Hub) <pzalewski@xxxxxxxxxxxxxxxxxxxx>