[PATCH 2/2] crypto: hisilicon/sec: use named initializers for acpi_device_id
From: Pawel Zalewski (The Capable Hub)
Date: Thu Sep 03 2026 - 13:20:57 EST
Use a designated initializer for the acpi_device_id fields
which makes the code more readable and consistent with how
lists are initialized in the rest of the kernel code base.
Also drop explicitly setting fields to 0 where it is redundant.
Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@xxxxxxxxxxxxxxxxxxxx>
---
drivers/crypto/hisilicon/sec/sec_drv.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/crypto/hisilicon/sec/sec_drv.c b/drivers/crypto/hisilicon/sec/sec_drv.c
index 2514a5e1f9b4..7d3fb8d67203 100644
--- a/drivers/crypto/hisilicon/sec/sec_drv.c
+++ b/drivers/crypto/hisilicon/sec/sec_drv.c
@@ -1285,7 +1285,7 @@ static const __maybe_unused struct of_device_id sec_match[] = {
MODULE_DEVICE_TABLE(of, sec_match);
static const __maybe_unused struct acpi_device_id sec_acpi_match[] = {
- { "HISI02C1", 0 },
+ { .id = "HISI02C1" },
{ }
};
MODULE_DEVICE_TABLE(acpi, sec_acpi_match);
--
2.43.0