[PATCH v2 0/4] phy: core: Add phy bulk helpers support
From: Inochi Amaoto
Date: Fri Sep 04 2026 - 04:52:15 EST
As discussed in [1], some drivers may do not care the difference between
phys. Instead, they only need to treat them as a group and operate them
together. This means a bulk operation is needed.
Add some bulk helper functions for phy core by referencing the design of
clock/reset subsystem. This can relieve the driver owners' life who needs
to handle many phys, as well as each phy error reporting.
[1] https://lore.kernel.org/linux-pci/ak9KzNFF26B0Kttz@ashevche-desk.local/
Changed from v1:
- https://lore.kernel.org/linux-phy/20260831025319.94886-1-inochiama@xxxxxxxxx/
patch 1:
1. Update document.
patch 2:
1. Fix document format.
2. Fix several document description.
patch 3:
1. Split into two patches: one for non devm helpers, one for devm helpers.
2. All the bulk helper now use unsigned int for counts.
3. Fix multiple the while loop statement.
4. Rename of_phy_get_parent_count() to of_phy_get_count().
5. Fix some 80 line function problems.
6. Use PTR_ERR_OR_ZERO() to simplify the error handle.
7. Fix zero value in the document
8. Use two separate release function for devm helpers.
Inochi Amaoto (4):
phy: core: Add common helper to add phy phandle device link
phy: core: Add common helper for get phy phandle by index
phy: core: Add phy bulk data helper functions
phy: core: Add managed phy bulk data helper functions
drivers/phy/phy-core.c | 700 +++++++++++++++++++++++++++++++++++++---
include/linux/phy/phy.h | 186 +++++++++++
2 files changed, 850 insertions(+), 36 deletions(-)
--
2.55.0