[PATCH 1/4] dma: dw: use designated initializers for acpi_device_id

From: Pawel Zalewski

Date: Fri Sep 04 2026 - 10:26:16 EST


Use a named initializer for the acpi_device_id fields which
makes the code more readable and consistent with how lists
are initialized in the rest of the kernel code base.

Signed-off-by: Pawel Zalewski <pzalewski@xxxxxxxxxxxxxxxxxxxx>
---
drivers/dma/dw/platform.c | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/drivers/dma/dw/platform.c b/drivers/dma/dw/platform.c
index c63fa52036d7f..5c1c97eb28a4a 100644
--- a/drivers/dma/dw/platform.c
+++ b/drivers/dma/dw/platform.c
@@ -141,14 +141,14 @@ MODULE_DEVICE_TABLE(of, dw_dma_of_id_table);

#ifdef CONFIG_ACPI
static const struct acpi_device_id dw_dma_acpi_id_table[] = {
- { "INTL9C60", (kernel_ulong_t)&dw_dma_chip_pdata },
- { "80862286", (kernel_ulong_t)&dw_dma_chip_pdata },
- { "808622C0", (kernel_ulong_t)&dw_dma_chip_pdata },
+ { .id = "INTL9C60", .driver_data = (kernel_ulong_t)&dw_dma_chip_pdata },
+ { .id = "80862286", .driver_data = (kernel_ulong_t)&dw_dma_chip_pdata },
+ { .id = "808622C0", .driver_data = (kernel_ulong_t)&dw_dma_chip_pdata },

/* Elkhart Lake iDMA 32-bit (PSE DMA) */
- { "80864BB4", (kernel_ulong_t)&xbar_chip_pdata },
- { "80864BB5", (kernel_ulong_t)&xbar_chip_pdata },
- { "80864BB6", (kernel_ulong_t)&xbar_chip_pdata },
+ { .id = "80864BB4", .driver_data = (kernel_ulong_t)&xbar_chip_pdata },
+ { .id = "80864BB5", .driver_data = (kernel_ulong_t)&xbar_chip_pdata },
+ { .id = "80864BB6", .driver_data = (kernel_ulong_t)&xbar_chip_pdata },

{ }
};

--
2.43.0