[PATCH 3/4] dma: qcom: use named initializers for acpi_device_id
From: Pawel Zalewski
Date: Fri Sep 04 2026 - 11:05:38 EST
Use a named initializer for the acpi_device_id fields which
makes the code more readable and consistent with how lists
are initialized in the rest of the kernel code base.
Also drop explicitly setting fields to 0 where it is redundant.
While we are at it - unify the list terminator to have
a single space between the brackets and no trailing
comma.
Signed-off-by: Pawel Zalewski <pzalewski@xxxxxxxxxxxxxxxxxxxx>
---
drivers/dma/qcom/hidma.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/dma/qcom/hidma.c b/drivers/dma/qcom/hidma.c
index c939635be21d..1349066b1544 100644
--- a/drivers/dma/qcom/hidma.c
+++ b/drivers/dma/qcom/hidma.c
@@ -935,10 +935,10 @@ static void hidma_remove(struct platform_device *pdev)
#if IS_ENABLED(CONFIG_ACPI)
static const struct acpi_device_id hidma_acpi_ids[] = {
- {"QCOM8061"},
- {"QCOM8062", HIDMA_MSI_CAP},
- {"QCOM8063", (HIDMA_MSI_CAP | HIDMA_IDENTITY_CAP)},
- {},
+ { .id = "QCOM8061" },
+ { .id = "QCOM8062", .driver_data = HIDMA_MSI_CAP },
+ { .id = "QCOM8063", .driver_data = (HIDMA_MSI_CAP | HIDMA_IDENTITY_CAP) },
+ { }
};
MODULE_DEVICE_TABLE(acpi, hidma_acpi_ids);
#endif
--
2.43.0