Re: [PATCH] crypto: amcc: trng: use devm_of_iomap()
From: Rosen Penev
Date: Fri Sep 04 2026 - 15:29:46 EST
On Fri, Sep 4, 2026 at 2:29 AM Herbert Xu <herbert@xxxxxxxxxxxxxxxxxxx> wrote:
>
> On Wed, Aug 12, 2026 at 11:57:47AM -0700, Rosen Penev wrote:
> > Convert of_iomap() to devm_of_iomap() so that the TRNG register
> > mapping is automatically unmapped on driver detach, eliminating
> > the need for manual iounmap() calls in the error and remove paths.
> >
> > Assisted-by: opencode:big-pickle
> > Signed-off-by: Rosen Penev <rosenp@xxxxxxxxx>
> > ---
> > drivers/crypto/amcc/crypto4xx_trng.c | 7 ++-----
> > 1 file changed, 2 insertions(+), 5 deletions(-)
>
> Please check Sashiko:
>
> https://sashiko.dev/#/patchset/20260812185747.79173-1-rosenp%40gmail.com
>
> Thanks,
So I guess conversion from void to int is needed beforehand.
> --
> Email: Herbert Xu <herbert@xxxxxxxxxxxxxxxxxxx>
> Home Page: http://gondor.apana.org.au/~herbert/
> PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt