Re: [PATCH v5 1/7] mm/memcontrol: flatten try_charge_memcg control flow

From: Shakeel Butt

Date: Fri Sep 04 2026 - 19:07:23 EST


On Mon, Aug 31, 2026 at 09:37:45AM -0700, Joshua Hahn wrote:
> Refactor try_charge_memcg by flattening the nested memsw/memory
> page_counter operations to separate the logic between the two.
>
> When page_counter_try_charge is made stock-aware, this flattening makes
> the control flow easier to follow since each page counter now has its
> own success/failure paths.
>
> No functional changes intended.
>
> Signed-off-by: Joshua Hahn <joshua.hahnjy@xxxxxxxxx>

Acked-by: Shakeel Butt <shakeel.butt@xxxxxxxxx>