Re: [PATCH v6 4/6] iio: pressure: dps310: add triggered buffer support

From: Rupesh Majhi

Date: Sun Sep 06 2026 - 06:08:18 EST


On Tue, 25 Aug 2026 12:06:12 +0300
Andy Shevchenko <andriy.shevchenko@xxxxxxxxx> wrote:

> Hmm... Is scoped_guard() too bad here?

Jonathan asked for the plain form on this handler in the v5 review:

It isn't necessary to use guard/scoped_guard() for all locks in a
driver if they actually hurt readability. I think that is the case
here.

So it stays as mutex_lock/unlock with the goto. guard() is kept where the
lock runs to the end of the function.

> Side note, at some point makes sense to move from 1000 to KILO.

The site above it is pre-existing, so both should move together in the
cleanup series rather than leaving one spelled each way here.

Rupesh