Re: [PATCH net-next 1/4] psp: refactor psp_dev_tx_key_del()
From: Willem de Bruijn
Date: Sun Sep 06 2026 - 13:09:43 EST
Daniel Zahka wrote:
> No functional changes.
>
> Lift the list deletion and tx spi validation code into
> callers. Deferred key deletion code paths will need similar checks
> that a tx key needs removal from the underlying device, but will
> diverge when it comes to list handling and when to call
> psp_dev_ops::tx_key_del().
>
> Also, move the predicate for tx key deletion into a helper for
> readability and reuse in later patches.
>
> Signed-off-by: Daniel Zahka <daniel.zahka@xxxxxxxxx>
Reviewed-by: Willem de Bruijn <willemb@xxxxxxxxxx>