Re: [PATCH v3 2/4] dmaengine: use dma_chan_name() helper to get per-channel device name
From: Amelie Delaunay
Date: Mon Sep 07 2026 - 05:09:27 EST
On 9/4/26 23:49, Frank.Li@xxxxxxxxxxx wrote:
From: Frank Li<Frank.Li@xxxxxxx>
Use the existing dma_chan_name() helper to obtain the per-channel device
name instead of open-coding: dev_name(chan->dev->device) /
dev_name(chan2dev())
Simplify the code and improve consistency.
No functional change intended.
Reviewed-by: Logan Gunthorpe<logang@xxxxxxxxxxxx>
Signed-off-by: Frank Li<Frank.Li@xxxxxxx>
Reviewed-by: Amelie Delaunay <amelie.delaunay@xxxxxxxxxxx> # For STM32
---
drivers/dma/dma-jz4780.c | 2 +-
drivers/dma/dw-axi-dmac/dw-axi-dmac-platform.c | 2 +-
drivers/dma/idma64.c | 2 +-
drivers/dma/loongson/loongson2-apb-dma.c | 2 +-
drivers/dma/mmp_pdma.c | 2 +-
drivers/dma/st_fdma.c | 2 +-
drivers/dma/stm32/stm32-dma3.c | 2 +-
drivers/dma/stm32/stm32-mdma.c | 2 +-
include/trace/events/tegra_apb_dma.h | 6 +++---
9 files changed, 11 insertions(+), 11 deletions(-)