Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
From: Oleg Nesterov
Date: Tue Sep 08 2026 - 02:59:34 EST
On 09/07, Ye Liu wrote:
>
> From: Ye Liu <liuye@xxxxxxxxxx>
>
> Replace the manual rcu_read_lock()/rcu_read_unlock() and guard(rcu)
> pairs combined with for_each_process(), for_each_thread() and
> for_each_process_thread() loops across kernel/ with the
> for_each_*_rculock() macros, which scope the RCU read lock to the
> loop body via scoped_guard(rcu).
>
> No functional change.
>
> Signed-off-by: Ye Liu <liuye@xxxxxxxxxx>
> Acked-by: Michal Hocko <mhocko@xxxxxxxx>
> ---
> Changes in v2:
> - Rename *_rcu to *_rculock
> - Rename stale 'unlock:' label to 'out:' in hung_task.c (Günther Noack)
> kernel/cpu.c | 4 +---
> kernel/freezer.c | 4 +---
> kernel/hung_task.c | 11 ++++-------
> kernel/locking/lockdep.c | 4 +---
> kernel/rcu/update.c | 4 +---
> kernel/sched/core.c | 3 +--
> kernel/sched/debug.c | 4 +---
> kernel/trace/fgraph.c | 8 ++------
> kernel/unwind/deferred.c | 3 +--
Reviewed-by: Oleg Nesterov <oleg@xxxxxxxxxx>