[PATCH 3/3] HID: surface-hid: use named initializers for acpi_device_id

From: Pawel Zalewski

Date: Tue Sep 08 2026 - 05:28:57 EST


Use a named initializer for the acpi_device_id fields which makes the code
more readable and consistent with how lists are initialized in the rest of
the kernel code base.

Unify the list terminator to have a single space between the brackets and
no trailing comma.

Signed-off-by: Pawel Zalewski <pzalewski@xxxxxxxxxxxxxxxxxxxx>
---
drivers/hid/surface-hid/surface_kbd.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/hid/surface-hid/surface_kbd.c b/drivers/hid/surface-hid/surface_kbd.c
index 0be01b5e74258..036829ba47d42 100644
--- a/drivers/hid/surface-hid/surface_kbd.c
+++ b/drivers/hid/surface-hid/surface_kbd.c
@@ -277,8 +277,8 @@ static void surface_kbd_remove(struct platform_device *pdev)
}

static const struct acpi_device_id surface_kbd_match[] = {
- { "MSHW0096" },
- { },
+ { .id = "MSHW0096" },
+ { }
};
MODULE_DEVICE_TABLE(acpi, surface_kbd_match);


--
2.43.0