RE: [PATCH] edac: use named initializers for acpi_device_id
From: David Thompson
Date: Tue Sep 08 2026 - 15:02:38 EST
> -----Original Message-----
> From: Pawel Zalewski <pzalewski@xxxxxxxxxxxxxxxxxxxx>
> Sent: Friday, September 4, 2026 10:42 AM
> To: Shravan Ramani <shravankr@xxxxxxxxxx>; David Thompson
> <davthompson@xxxxxxxxxx>; Borislav Petkov <bp@xxxxxxxxx>; Tony Luck
> <tony.luck@xxxxxxxxx>; Zhao Qunqin <zhaoqunqin@xxxxxxxxxxx>
> Cc: linux-edac@xxxxxxxxxxxxxxx; linux-kernel@xxxxxxxxxxxxxxx; Pawel Zalewski
> <pzalewski@xxxxxxxxxxxxxxxxxxxx>
> Subject: [PATCH] edac: use named initializers for acpi_device_id
>
> Use a named initializer for the acpi_device_id fields which makes the code
> more readable and consistent with how lists are initialized in the rest of the
> kernel code base. Also drop explicitly setting fields to 0 where it is redundant.
>
> While we are at it - unify the list terminator to have a single space between the
> brackets and no trailing comma.
>
> Signed-off-by: Pawel Zalewski <pzalewski@xxxxxxxxxxxxxxxxxxxx>
> ---
Reviewed-by: David Thompson <davthompson@xxxxxxxxxx>