Re: [PATCH 1/2] crypto: ccp: use named initializers for acpi_device_id

From: Tom Lendacky

Date: Tue Sep 08 2026 - 16:51:49 EST


On 9/3/26 10:42, Pawel Zalewski (The Capable Hub) wrote:
> Use a named initializer for the acpi_device_id fields which
> makes the code more readable and consistent with how lists
> are initialized in the rest of the kernel code base.
>
> While we are at it - unify the list terminator to have
> a single space between the brackets and no trailing
> comma.
>
> Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@xxxxxxxxxxxxxxxxxxxx>

Acked-by: Tom Lendacky <thomas.lendacky@xxxxxxx>

> ---
> drivers/crypto/ccp/sp-platform.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/crypto/ccp/sp-platform.c b/drivers/crypto/ccp/sp-platform.c
> index 3f9843fa77827..c7ac840cbe136 100644
> --- a/drivers/crypto/ccp/sp-platform.c
> +++ b/drivers/crypto/ccp/sp-platform.c
> @@ -40,8 +40,8 @@ static const struct sp_dev_vdata dev_vdata[] = {
> };
>
> static const struct acpi_device_id sp_acpi_match[] = {
> - { "AMDI0C00", (kernel_ulong_t)&dev_vdata[0] },
> - { },
> + { .id = "AMDI0C00", .driver_data = (kernel_ulong_t)&dev_vdata[0] },
> + { }
> };
> MODULE_DEVICE_TABLE(acpi, sp_acpi_match);
>
>