Re: [PATCH v9 2/5] x86/asm, x86/boot: expose inline memcmp()

From: Mauricio Faria de Oliveira

Date: Tue Sep 08 2026 - 18:13:41 EST


On 2026-09-08 16:32, Borislav Petkov wrote:
> On Tue, Sep 08, 2026 at 03:04:53PM -0300, Mauricio Faria de Oliveira wrote:
>> Boris, perhaps the approach here could be changed to add an actual
>> memcmp()-like inline implementation (e.g., as provided in a previous
>> revision, without return value differences), or continue with the
>> memeq()-like memcmp() from arch/x86/boot/ but rename it to memeq() ?
>
> Nah, new functionality is not needed. We can add it later when it is really needed.

Ack, and to confirm: not rename the existing one, either?

--
Mauricio