Re: [PATCH v3 10/21] PCI/TSM: Rename pf0 to host
From: Jonathan Cameron
Date: Tue Sep 08 2026 - 19:07:48 EST
On Tue, 1 Sep 2026 11:03:36 +1000
alistair23@xxxxxxxxx wrote:
> From: Alistair Francis <alistair.francis@xxxxxxx>
>
> Rename pci_tsm_pf0 to pci_tsm_host (and rename variables and function
> names from pf0 to host) as part of converting pci_tsm_host
> to be any device that knows how to speak any of CMA, IDE, or
> TDISP.
I'm not against the change, but I would like at least one example of
'what' other type of device you plan to use this for.
vf or something else?
>
> This commit just renames the functions and provides no functional
> change. That will happen in the next commit.
>
> Signed-off-by: Alistair Francis <alistair.francis@xxxxxxx>
> ---
> drivers/crypto/ccp/sev-dev-tio.h | 4 +-
> drivers/crypto/ccp/sev-dev-tsm.c | 12 ++---
> drivers/pci/tsm.c | 84 ++++++++++++++++----------------
> include/linux/pci-tsm.h | 18 ++++---
> 4 files changed, 61 insertions(+), 57 deletions(-)
>