Re: [PATCH 1/3] workqueue: Add for_each_node_with_fallback()
From: Breno Leitao
Date: Wed Sep 09 2026 - 07:19:55 EST
On Tue, Sep 01, 2026 at 11:09:27AM -1000, Tejun Heo wrote:
> Per-node arrays in workqueue carry an extra slot at nr_node_ids for
> NUMA_NO_NODE, and iterating them open-codes for_each_node() plus separate
> handling of that slot. Add for_each_node_with_fallback() and convert
> alloc/free_node_nr_active().
Yea, that makes the code easier to read and reason about.
> Signed-off-by: Tejun Heo <tj@xxxxxxxxxx>
Reviewed-by: Breno Leitao <leitao@xxxxxxxxxx>