Re: [PATCH v4 09/17] mm/huge_memory: rename remap_page() to remap_folio()
From: David Hildenbrand (Arm)
Date: Wed Sep 09 2026 - 14:35:59 EST
On 9/8/26 17:17, Kiryl Shutsemau wrote:
> On Tue, Sep 08, 2026 at 02:12:13AM +0800, Kairui Song via B4 Relay wrote:
>> @@ -3636,10 +3636,17 @@ bool unmap_huge_pmd_locked(struct vm_area_struct *vma, unsigned long addr,
>> return __discard_anon_folio_pmd_locked(vma, addr, pmdp, folio);
>> }
>>
>> -static void remap_page(struct folio *folio, unsigned long nr, int flags)
>> +static void remap_folio(struct folio *folio, unsigned long nr, int flags)
>
> You opted out of indicating that the function target anon pages as David
> suggested? remap_anon_folio() seems to be fitting better.
Yeah, let's use that unless there is a good reason not to.
--
Cheers,
David