Re: [PATCH 04/12] mm/sparse: rename and cleanup sparse_init_nid()

From: Oscar Salvador (SUSE)

Date: Thu Sep 10 2026 - 03:48:23 EST


On Wed, Sep 09, 2026 at 03:32:57PM +0200, David Hildenbrand (Arm) wrote:
> Let's rename it to "sparse_metadata_init_nid", avoid the "pnum" terminology
> and drop the function comment. Further, rename the "map" variable to
> "mem_map" for consistency with other functions.
>
> Signed-off-by: David Hildenbrand (Arm) <david@xxxxxxxxxx>

Yap, solid cleanup. I cannot remember what pnum was meant to be.

Acked-by: Oscar Salvador <osalvador@xxxxxxx>



--
Oscar Salvador
SUSE Labs