Re: [PATCH] dmaengine: bestcomm: use devm_platform_get_and_ioremap_resource() to simplify code

From: Vinod Koul

Date: Thu Sep 10 2026 - 11:44:10 EST


On 09-09-26, 16:26, Rosen Penev wrote:
> Replace the open-coded resource lookup, request_mem_region, ioremap and
> the manual iounmap/release_mem_region cleanup in probe/remove with the
> managed devm_platform_get_and_ioremap_resource() helper. This removes the
> now-unused error-unmap/release paths and simplifies probing.
>
> Fix a resource size mismatch between allocating and freeing where
> request_mem_region() and release_mem_region() hopefully use the same size
> but is not guarenteed.
>
> Signed-off-by: Rosen Penev <rosenp@xxxxxxxxx>
> ---
> v4: fix subject

Where is v4 in the subject..

Nevertheless this fails for me, can you please rebase

--
~Vinod