Re: (subset) [PATCH v3 01/11] drm/atomic: colorop: Rename state to state_to_destroy
From: Maxime Ripard
Date: Fri Sep 11 2026 - 09:34:58 EST
On Tue, 08 Sep 2026 16:35:02 +0200, Maxime Ripard wrote:
> The atomic state tracking structures used to have a generic state
> field to track the state to free when tearing down the
> drm_atomic_commit. It has since been renamed to state_to_destroy in
> __drm_planes_state, __drm_crtcs_state, __drm_connnectors_state, and
> __drm_private_objs_state to better describe its purpose.
>
> The colorop support has been added after that rename, but
> __drm_colorops_state still uses the old state name. Rename it to
> state_to_destroy for consistency, and add the matching kerneldoc.
>
> [...]
Applied to misc/kernel.git (drm-misc-next)
[01/11] drm/atomic: colorop: Rename state to state_to_destroy
commit: 38d8b5a35367246dee147d48ea6d5cd6644de5d5
Thanks!
Maxime