Re: [PATCH net-next 04/10] netlink: specs: rt-link: fix netkit-policy names
From: Daniel Borkmann
Date: Mon Sep 14 2026 - 04:20:36 EST
On 9/12/26 2:36 AM, Jakub Kicinski wrote:
On Fri, 11 Sep 2026 15:26:29 -0700 Jakub Kicinski wrote:
On Fri, 11 Sep 2026 21:41:30 +0000 Asbjørn Sloth Tønnesen wrote:
Correct the names of these `enum netkit_action` constants:
- NETKIT_PASS is 0, so "pass", not "forward".
- NETKIT_DROP is 2, so "drop", not "blackhole".
Note, the other enum members are not used in netlink, and
are not allowed by netkit_check_policy().
Looks right tho may be intentional, so the other option would be to add
#define aliases for the spec names.
Ah, looks like some of the selftests use "forward" by name
You'll have to fix those
And this renaming is also just bikeshedding. Its fine as is and
I don't see a reason this must change. Its not mandatory that this
must be exactly named pass/drop just because the internally used
enums (implementation detail) are such.