Re: [PATCH 06/12] mm/sparse: rename __highest_present_section_nr to __highest_used_section_nr

From: David Hildenbrand (Arm)

Date: Mon Sep 14 2026 - 11:42:29 EST


On 9/14/26 11:45, Mike Rapoport wrote:
>> /*
>> - * There are a number of times that we loop over NR_MEM_SECTIONS,
>> - * looking for section_present() on each. But, when we have very
>> - * large physical address spaces, NR_MEM_SECTIONS can also be
>> - * very large which makes the loops quite long.
>> - *
>> - * Keeping track of this gives us an easy way to break out of
>> - * those loops early.
>> + * Looping over all memory sections is expensive, especially if NR_MEM_SECTIONS
> ... all possible ... maybe?

Ack, thanks!

--
Cheers,

David