Re: [PATCH v3 5/5] pinctrl: renesas: rzt2h: add a helper for reading PFC
From: Geert Uytterhoeven
Date: Mon Sep 14 2026 - 12:54:07 EST
On Sun, 13 Sept 2026 at 21:58, Cosmin Tanislav
<cosmin-gabriel.tanislav.xa@xxxxxxxxxxx> wrote:
> Introduce a rzt2h_pin_read_pfc() helper and replace the open-coded
> implementation inside rzt2h_gpio_get_direction() to simplify the code.
>
> While at it, use field_get() with PFC_PIN_MASK to avoid the manual shift
> and mask.
>
> Signed-off-by: Cosmin Tanislav <cosmin-gabriel.tanislav.xa@xxxxxxxxxxx>
Reviewed-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx>
i.e. will queue in renesas-pinctrl for v7.4.
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds