Re: [PATCH v2] hwmon: use named initializers for acpi_device_id
From: Guenter Roeck
Date: Tue Sep 15 2026 - 13:00:11 EST
On 9/15/26 06:48, Pawel Zalewski wrote:
Use a designated initializer for the acpi_device_id fields which makes the
code more readable and consistent with how lists are initialized in the
rest of the kernel code base. Also drop explicitly setting fields to 0
where it is redundant.
Unify the list terminator to have a single space between the brackets and
no trailing comma.
It also replaces pointers to empty strings with NULL pointers,
which is a functional change and still neither documented nor explained.
Guenter