Re: [PATCHv5] dmaengine: bestcomm: use devm_platform_get_and_ioremap_resource() to simplify code
From: Vinod Koul
Date: Tue Sep 15 2026 - 14:42:01 EST
On Tue, 15 Sep 2026 00:28:53 -0700, Rosen Penev wrote:
> Replace the open-coded resource lookup, request_mem_region, ioremap and
> the manual iounmap/release_mem_region cleanup in probe/remove with the
> managed devm_platform_get_and_ioremap_resource() helper. This removes the
> now-unused error-unmap/release paths and simplifies probing.
>
> Fix a resource size mismatch between allocating and freeing where
> request_mem_region() and release_mem_region() hopefully use the same size
> but is not guarenteed.
>
> [...]
Applied, thanks!
[1/1] dmaengine: bestcomm: use devm_platform_get_and_ioremap_resource() to simplify code
commit: 0a8dda0a15d3926422d286567f945a05328a4ac6
Best regards,
--
~Vinod