Re: [PATCH v3 0/4] kho: rename "scratch" to "bootmem"

From: Mike Rapoport

Date: Thu Sep 24 2026 - 04:36:19 EST


On Tue, 22 Sep 2026 06:13:12 +0200, Pratyush Yadav wrote:
> kho: rename "scratch" to "bootmem"
>
> From: "Pratyush Yadav (Google)" <pratyush@xxxxxxxxxx>
>
> The term "KHO scratch" is vague and overloaded. It does not accurately
> describe what the memory is for. This was discussed previously at [0].
> The conclusion was to rename "KHO scratch" to "KHO bootmem", since this
> is memory passed by the previous kernel for early boot allocations.
>
> [...]

Applied to kho-bootmem branch of liveupdate/linux.git tree, thanks!

[1/4] memblock: get rid of CONFIG_MEMBLOCK_KHO_SCRATCH
commit: 5e309f53050f33faf74f55332f359099d7346464
[2/4] memblock: rename KHO_SCRATCH to KHO_NOPRSRV
commit: 05a84ceadf7024be320e2ba82fe709db4a4180bd
[3/4] kho: rename KHO scratch to KHO bootmem
commit: 85d3615cea17968788aa6581fd242e34d8953e58
[4/4] kho: rename kho_scratch= commandline parameter to kho_bootmem=
commit: 8fe64603a47506c3b357002460c3a9c0d8d4d321

tree: https://git.kernel.org/pub/scm/linux/kernel/git/liveupdate/linux
branch: kho-bootmem

--
Sincerely yours,
Mike.