Re: [PATCH v5 2/6] virt: tdx-guest: Give the Quote buffer an explicit type
From: Edgecombe, Rick P
Date: Mon Sep 28 2026 - 15:15:07 EST
On Mon, 2026-09-28 at 03:08 -0700, Peter Fang wrote:
> The Quote buffer is always a "struct tdx_quote_buf", but its global
> pointer is a "void *". A function would have to convert it back to make
> sense of it.
>
> Declare the global with its actual type, and give it a better name.
>
> This creates variable shadowing in wait_for_quote_completion(), so
> rename its parameter for clarity.
>
> AI was used under supervision to collect/apply feedback, review code and
> workshop logs.
>
> Signed-off-by: Peter Fang <peter.fang@xxxxxxxxx>
> ---
Reviewed-by: Rick Edgecombe <rick.p.edgecombe@xxxxxxxxx>