Re: [PATCH v3 28/40] mm: rename is_vm_hugetlb_page() to vma_is_hugetlb()

From: Zi Yan

Date: Mon Sep 28 2026 - 22:19:48 EST


On Thu Sep 17, 2026 at 12:22 PM EDT, Lorenzo Stoakes (ARM) wrote:
> The is_vm_hugetlb_page() predicate is badly named - the mapping can span
> more than a page and it is inconsistent with other VMA predicates that
> typically are prefixed by vma_.
>
> Rename to vma_is_hugetlb() for consistency, and while we're here update
> some VM_BUG_ON_VMA() to VM_WARN_ON_ONCE_VMA() as to avoid unnecessary
> oopses.
>
> No functional change intended.
>
> Acked-by: Marc Zyngier <maz@xxxxxxxxxx>
> Acked-by: Claudio Imbrenda <imbrenda@xxxxxxxxxxxxx>
> Acked-by: Anup Patel <anup@xxxxxxxxxxxxxx>
> Signed-off-by: Lorenzo Stoakes (ARM) <ljs@xxxxxxxxxx>
> ---
> arch/arm64/kvm/mmu.c | 4 ++--
> arch/powerpc/mm/book3s64/radix_tlb.c | 6 +++---
> arch/powerpc/mm/nohash/e500_hugetlbpage.c | 2 +-
> arch/powerpc/mm/nohash/tlb.c | 2 +-
> arch/riscv/kvm/mmu.c | 2 +-
> arch/riscv/mm/tlbflush.c | 2 +-
> arch/s390/mm/gmap_helpers.c | 6 +++---
> arch/sparc/mm/init_64.c | 2 +-
> drivers/gpu/drm/drm_gpusvm.c | 2 +-
> fs/coredump.c | 2 +-
> fs/hugetlbfs/inode.c | 2 +-
> fs/proc/task_mmu.c | 8 ++++----
> include/asm-generic/tlb.h | 2 +-
> include/linux/hugetlb.h | 4 ++--
> include/linux/mm.h | 19 ++++++++++++++++---
> include/linux/rmap.h | 2 +-
> kernel/events/core.c | 2 +-
> kernel/sched/fair.c | 2 +-
> mm/gup.c | 4 ++--
> mm/huge_memory.c | 2 +-
> mm/hugetlb.c | 14 +++++++-------
> mm/internal.h | 2 +-
> mm/madvise.c | 4 ++--
> mm/memory.c | 12 ++++++------
> mm/mempolicy.c | 2 +-
> mm/migrate_device.c | 2 +-
> mm/mmap.c | 2 +-
> mm/mmu_gather.c | 2 +-
> mm/mprotect.c | 2 +-
> mm/mremap.c | 6 +++---
> mm/page_vma_mapped.c | 4 ++--
> mm/pagewalk.c | 2 +-
> mm/swapfile.c | 2 +-
> mm/userfaultfd.c | 26 +++++++++++++-------------
> mm/vma.c | 8 ++++----
> mm/vmscan.c | 2 +-
> tools/testing/vma/include/stubs.h | 2 +-
> 37 files changed, 92 insertions(+), 79 deletions(-)
>
Makes sense

Acked-by: Zi Yan <ziy@xxxxxxxxxx>

--
Best Regards,
Yan, Zi