[PATCH v3 0/6] mm: Unify device DAX and HugeTLB vmemmap population paths

From: Muchun Song

Date: Tue Sep 29 2026 - 01:33:23 EST


This v3 is based on mm-new commit 2ddb90ee544a, which contains v5 of
"mm: Switch device DAX to section-based vmemmap optimization" [1].

This series is split out from the earlier, larger series "mm: Generalize
HVO for HugeTLB and device DAX" [2]. While the parent series generalizes
vmemmap optimization across HugeTLB and device DAX, this subset addresses
a single, self-contained step: unifying their vmemmap population paths.

After the preceding Device DAX conversion, both HugeTLB and Device DAX
describe optimized vmemmap mappings through memory-section metadata and
use per-zone shared tail vmemmap pages. The generic code, however, still
carries a Device DAX-specific population flag and compound-page population
path, along with arguments and helpers needed only by that path.

This series first removes VMEMMAP_POPULATE_DAX and moves selection and
reference handling for the shared tail page into the common vmemmap
population path. It then removes the generic Device DAX-specific
compound-page population path and routes section vmemmap population
through vmemmap_populate(). The powerpc radix path continues to use its
architecture-specific compound-page population implementation for
optimizable sections.

The remaining patches remove the unused ptpfn argument, open-code
vmemmap_populate_address() now that no caller needs its returned PTE, and
add a warning for inconsistent zone initialization of shared tail vmemmap
pages.

This is the fourth smaller step toward the broader HVO generalization.
After this series, HugeTLB and Device DAX use the same population model
instead of parallel generic paths, while powerpc keeps its
architecture-specific implementation.

[1] https://lore.kernel.org/20260927025441.741633-1-songmuchun@xxxxxxxxxxxxx/
[2] https://lore.kernel.org/20260513130542.35604-1-songmuchun@xxxxxxxxxxxxx/

v3:
- Rebase onto mm-new commit 2ddb90ee544a, which contains v5 of the Device
DAX section-based vmemmap series.
- Document the exact dependency order as suggested by David Hildenbrand
and Ritesh Harjani.
- Use the public order-based optimization predicate in the powerpc path.
- Collect Acked-by tags from Qi Zheng.

v2: https://lore.kernel.org/20260924075259.2013039-1-songmuchun@xxxxxxxxxxxxx/
- Expand the comments around the slab initialization boundary as suggested
by Qi Zheng.
- Collect Acked-by tags from Qi Zheng.
- Defer the patch making vmemmap_populate_compound_pages() static to a
follow-up series that cleans up the powerpc vmemmap population code.
- Add a new patch to warn about mismatched zone IDs between a page and its
shared tail vmemmap page.

v1: https://lore.kernel.org/20260913083734.86802-1-songmuchun@xxxxxxxxxxxxx/

Muchun Song (6):
mm/sparse-vmemmap: drop VMEMMAP_POPULATE_DAX
mm/sparse-vmemmap: support device DAX in common vmemmap path
mm/sparse-vmemmap: drop Device DAX-specific population path
mm/sparse-vmemmap: remove the unused ptpfn argument
mm/sparse-vmemmap: open-code vmemmap_populate_address()
mm/mm_init: add zone mismatch warning during page init

arch/powerpc/mm/book3s64/radix_pgtable.c | 3 +
mm/mm_init.c | 5 +-
mm/sparse-vmemmap.c | 208 ++++++-----------------
3 files changed, 63 insertions(+), 153 deletions(-)


base-commit: 2ddb90ee544ae97215afc4698dc223293997cc43
--
2.54.0