Re: [PATCH] e1000e: rename init/exit module functions to avoid confusion with e1000
From: Joe Damato
Date: Tue Sep 29 2026 - 19:15:23 EST
On Tue, Sep 15, 2026 at 02:26:38PM +0200, Filip Balluch wrote:
> The e1000e driver uses e1000_init_module and e1000_exit_module as its
> module init/exit function names, which are identical to those used by the
> older e1000 driver. Rename them to e1000e_init_module and
> e1000e_exit_module to clearly distinguish e1000e from the legacy e1000
> driver.
>
> Signed-off-by: Filip Balluch <fballuch@xxxxxxxxxx>
> ---
> drivers/net/ethernet/intel/e1000e/netdev.c | 16 ++++++++--------
> 1 file changed, 8 insertions(+), 8 deletions(-)
Reviewed-by: Joe Damato <joe@xxxxxxx>