[PATCH] init: simplify initramfs.o build rule
From: Yuntao Wang
Date: Tue Sep 29 2026 - 22:00:25 EST
CONFIG_BLK_DEV_INITRD is known to be enabled in the else branch,
so there is no need to use obj-$(CONFIG_BLK_DEV_INITRD). Use obj-y
directly to make the build rule clearer.
Also, reorder the condition to make the code easier to follow.
No functional change.
Signed-off-by: Yuntao Wang <yuntao.wang@xxxxxxxxx>
---
init/Makefile | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/init/Makefile b/init/Makefile
index d6f75d8907e0..9102fc34c0cc 100644
--- a/init/Makefile
+++ b/init/Makefile
@@ -6,10 +6,10 @@
ccflags-y := -fno-function-sections -fno-data-sections
obj-y := main.o version.o mounts.o
-ifneq ($(CONFIG_BLK_DEV_INITRD),y)
-obj-y += noinitramfs.o
+ifeq ($(CONFIG_BLK_DEV_INITRD),y)
+obj-y += initramfs.o
else
-obj-$(CONFIG_BLK_DEV_INITRD) += initramfs.o
+obj-y += noinitramfs.o
endif
obj-$(CONFIG_GENERIC_CALIBRATE_DELAY) += calibrate.o
obj-$(CONFIG_INITRAMFS_TEST) += initramfs_test.o
--
2.55.0