[tip: x86/platform] x86/platform/olpc: Use named initializers for acpi_device_id

From: tip-bot2 for Pawel Zalewski (The Capable Hub)

Date: Tue Sep 29 2026 - 23:40:37 EST


The following commit has been merged into the x86/platform branch of tip:

Commit-ID: edb2b6d8ea88659679787231253e1acefca63f28
Gitweb: https://git.kernel.org/tip/edb2b6d8ea88659679787231253e1acefca63f28
Author: Pawel Zalewski (The Capable Hub) <pzalewski@xxxxxxxxxxxxxxxxxxxx>
AuthorDate: Fri, 07 Aug 2026 13:38:33 +01:00
Committer: Borislav Petkov (AMD) <bp@xxxxxxxxx>
CommitterDate: Tue, 29 Sep 2026 20:35:00 -07:00

x86/platform/olpc: Use named initializers for acpi_device_id

Use a named initializer for the acpi_device_id fields which makes the code
more readable and consistent with how lists are initialized in the rest of the
kernel code base. Also drop explicitly setting fields to 0 where it is
redundant.

While at it - unify the list terminator to have a single space between the
brackets and no trailing comma.

Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@xxxxxxxxxxxxxxxxxxxx>
Signed-off-by: Borislav Petkov (AMD) <bp@xxxxxxxxx>
Link: https://patch.msgid.link/20260807-acpi-platform-v1-1-1507662916ed@xxxxxxxxxxxxxxxxxxxx
---
arch/x86/platform/olpc/olpc-xo15-sci.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/x86/platform/olpc/olpc-xo15-sci.c b/arch/x86/platform/olpc/olpc-xo15-sci.c
index 75ed6ce..a13dd6b 100644
--- a/arch/x86/platform/olpc/olpc-xo15-sci.c
+++ b/arch/x86/platform/olpc/olpc-xo15-sci.c
@@ -210,8 +210,8 @@ static int xo15_sci_resume(struct device *dev)
static SIMPLE_DEV_PM_OPS(xo15_sci_pm, NULL, xo15_sci_resume);

static const struct acpi_device_id xo15_sci_device_ids[] = {
- {"XO15EC", 0},
- {"", 0},
+ { .id = "XO15EC" },
+ { }
};

static struct platform_driver xo15_sci_drv = {