Re: [PATCH 1/7] ARM: dts: axis: artpec6: avoid _ in node names

From: Krzysztof Kozlowski

Date: Wed Sep 30 2026 - 01:25:58 EST


On 28/09/2026 14:04, Henrik Grimler wrote:
> Node names should preferably not use _, use - instead. Fixes
> dt-check-style strict mode warnings:
>
> axis/artpec6.dtsi:91: [node-name] node name "ext_clk" is using discouraged style
> axis/artpec6.dtsi:97: [node-name] node name "eth_phy_ref_clk" is using discouraged style
> axis/artpec6.dtsi:189: [node-name] node name "pcie_ep" is using discouraged style
>
> Signed-off-by: Henrik Grimler <henrik.grimler@xxxxxxxx>
> ---
> arch/arm/boot/dts/axis/artpec6.dtsi | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/arch/arm/boot/dts/axis/artpec6.dtsi b/arch/arm/boot/dts/axis/artpec6.dtsi
> index 037157e6c5ee..ce642dcc754e 100644
> --- a/arch/arm/boot/dts/axis/artpec6.dtsi
> +++ b/arch/arm/boot/dts/axis/artpec6.dtsi
> @@ -88,13 +88,13 @@ scu@faf00000 {
> };
>
> /* Main external clock driving CPU and peripherals */
> - ext_clk: ext_clk {
> + ext_clk: ext-clk {

This will change the name of the clock. Did you verify that it is fine?

Best regards,
Krzysztof